Cara Install OpenVPN di OpenWRT

OpenVPN merupakan projek Open Source yang menerapkan Virtual Private Network untuk mengamankan akses internet. Dengan menggunakan OpenVPN kita dapat menyembunyikan identitas alamat IP kita yang sebenarnya.

Menginstal OpenVPN di Router atau OpenWRT cukup mudah. Pertama login ke ssh router dengan cara berikut;

1
$ ssh root@192.168.1.1

Setelah berhasil masuk ke ssh router, selanjutnya kita perlu melakukan update repository OpenWRT terlebih dahulu gar database aplikasi siap untuk diinstal.

1
opkg update

Setelah opkg update berhasil selanjutnya tinggal menginstall OpenVPN dengan cara mengetikan perintah berikut;

1
opkg install openvpn-openssl

kurang lebih proses instal seperti gambar di bawah. Meski sebelum membuat post ini, di router Rureka sudah terinstall OpenVPN.

Setelah berhasil menginstall OpenVPN kita masih perlu mengatur firewall dan interface agar OpenVPN bisa berjalan semestinya.

Berikut cara mengatur firewall dan interface OpenVPN.

1
nano /etc/config/firewall

Jika nano belum terinstal bisa menginstalnya dengan cara berikut;

1
opkg install nano

setelah menjalankan peritah nano /etc/config/firewall nanti tampilannya seperti berikut;

kemudian tinggal scroll sampai akhir baris dan paste kan config ini.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
config zone
option name 'openvpn'
option input 'ACCEPT'
option forward 'REJECT'
option output 'ACCEPT'
option network 'openvpn tunnel'
option masq '1'
option mtu_fix '1'

config forwarding
option dest 'wan'
option src 'openvpn'

config forwarding
option dest 'openvpn'
option src 'lan'

Untuk menyimpan config tadi tekan tombol keyboard ctrl + x dan kemudian tekan tombol keyboard Y.

Setelah mengatur firewall untuk OpenVPN selanjutnya mengatur untuk interfacenya.

1
nano /etc/config/network

dan paste kan config berikut dibagian baris paling bawah

1
2
3
4
5
6
7
config interface 'openvpn'
option proto 'none'
option ifname 'tun0'

config interface 'tunnel'
option proto 'none'
option ifname 'tap0'

Comments